Как изменить расширение нескольких файлов рекурсивно из командной строки?

У меня много файлов с .АБВ расширение и хотите изменить их .edefg
Как это сделать из командной строки ?

У меня корневая папка с множеством подпапок, поэтому решение должно работать рекурсивно.

+484
whamer100 27 янв. 2011 г., 10:19:33
24 ответов

Похоже, что эта ошибка может быть проигнорирована и после перезагрузки драйвер Nvidia будут загружены правильно.

+972
Seggix 03 февр. '09 в 4:24

Удаление Windows-это легко, когда у вас в Ubuntu установлено.

  1. Открыть дисковой утилиты в Ubuntu
  2. Выберите раздел, где установлена Windows и отформатировать его.

Этого достаточно, чтобы освободить свободное пространство.

Тем не менее, если вы хотите удалить Windows запись от жратвы, следуйте по ссылке.

+970
Daniel Martinez B 12 апр. 2012 г., 16:46:53

По помогает от pschrammel на support.mozilla.org я удалил ~/.пульс-печенье каталог, то это решает проблему. https://support.mozilla.org/en-US/questions/932643

+898
Laurel K Pope 19 февр. 2014 г., 19:46:05

Один мой знакомый (несколько новых для Linux) после недавнего обновления с 10.10 до 11.04 и его ОС прорвался с обновлением. Несколько минут поиск и устранение неисправностей показал, что виновником был ядром PAE, что обновление решил установить с ней определили у него 4 ГБ оперативной памяти, а также физио. Более конкретно обновить забыли установить Линукс-заголовки-общие-Пае , необходимых закрытым исходным кодом драйверов NVIDIA.

Я не совсем уверен, как сообщить об этой ошибке разработчикам. Его легко исправить (после загрузки в non-PAE ядра и установки пакета все работало), но они поощряют пользователей, чтобы использовать встроенную систему сообщений об ошибках и я не совсем уверен, как сообщить об обновлении ошибки.

+869
Matthew Estock 19 июн. 2017 г., 21:20:04

Возможные Дубликаты:
Отсутствует меню в Lotus Notes 8 и затмение в единстве

Я заметил, что когда я установил Eclipse (из репозитория), что файл, Правка и т. д. меню не в глобальном/бар appmenu. Есть ли способ исправить это?

+860
zzRayzz 17 янв. 2011 г., 3:21:15

Когда я запускаю vmplayer, он обнаруживает, что ядро изменилось, и как обычно предложит скомпилировать и загрузить необходимые модули. Однако, он никогда не становится дальше. Когда вы выберете установки, он просто уходит молча без ошибок или каких-либо дополнительных действий. Что должно произойти, заключается в том, что апдейтер модуль ядра VMware должен работать. Это не так.

Пожалуйста, обратите внимание, это не то же самое, как на вопрос ответил Здесь, что путь к ядру заголовки, так что я могу установить VMware?, которая за счет правильной заголовочные файлы не там, где они должны быть. Мой никогда не так далеко, и к тому же я убедился, что у меня есть все последние заголовочные файлы для моего 3.8.0-19-generic ядро.

+824
Cody Parks 17 июл. 2019 г., 17:00:14

Я хочу установить jMonkey двигателя системы так, что все пользователи могут использовать его.

Где я могу поставить эти файлы?

$ разархивировать -м jME2_0_1-StableDistribution.zip
$ дерево -ФН jME2_0_1-StableDistribution/jME2_0_1-StableDistribution/
jME2_0_1-StableDistribution/jME2_0_1-StableDistribution/
|-- jme-audio.jar
|-- jme-awt.jar
|-- jme-collada.jar
|-- jme-editors.jar
|-- jme-effects.jar
|-- jme-font.jar
|-- jme-gamestates.jar
|-- jme.jar
|-- jme-model.jar
|-- jme-ogrexml.jar
|-- jme-scene.jar
|-- jme-swt.jar
|-- jme-terrain.jar
`-- Либ/
 |-- jme-colladabinding.jar
 |-- jme-colladabinding-src.jar
 |-- инструментов/
 | |-- CHANGELOG.txt
 | |-- COPYRIGHT.txt
 | |-- gluegen-rt.jar
 | |-- jogl.jar
 | |-- LICENSE-JOGL-1.1.1.txt
 | `-- родной/
 | |-- linux_amd64/
 | | |-- libgluegen-РТ.так
 | | |-- libjogl_awt.так
 | | |-- libjogl_cg.так
 | | `-- libjogl.так
 | |-- linux_i586/
 | | |-- libgluegen-РТ.так
 | | |-- libjogl_awt.так
 | | |-- libjogl_cg.так
 | | `-- libjogl.так
 | |-- видео/
 | | |-- libgluegen-РТ.jnilib по
 | | |-- libjogl_awt.jnilib по
 | | |-- libjogl_cg.jnilib по
 | | `-- libjogl.jnilib по
 | |-- solaris_i586/
 | | |-- libgluegen-РТ.так
 | | |-- libjogl_awt.так
 | | |-- libjogl_cg.так
 | | `-- libjogl.так
 | |-- windows_amd64/
 | | |-- gluegen-rt.dll
 | | |-- jogl_awt.dll
 | | |-- jogl_cg.dll
 | | `-- jogl.dll
 | `-- windows_i586/
 | |-- gluegen-rt.dll
 | |-- jogl_awt.dll
 | |-- jogl_cg.dll
 | `-- jogl.dll
 |-- jorbis/
 | |-- copying.txt
 | `-- jorbis-0.0.17.jar
 |-- с JUnit/
 | `-- junit-4.1.jar
 |-- lwjgl/
 | |-- jinput.jar
 | |-- LICENSE.txt
 | |-- lwjgl.jar
 | |-- lwjgl_util_applet.jar
 | |-- lwjgl_util.jar
 | `-- родной/
 | |-- Линукс/
 | | |-- libjinput-linux64.так
 | | |-- libjinput-Линукс.так
 | | |-- liblwjgl64.так
 | | |-- liblwjgl.так
 | | |-- libopenal64.так
 | | `-- libopenal.так
 | |-- видео/
 | | |-- libjinput-на OSX.jnilib по
 | | |-- liblwjgl.jnilib по
 | | `-- в OpenAL.dylib нужна
 | |-- Солярис/
 | | |-- liblwjgl.так
 | | `-- libopenal.так
 | `-- окна/
 | |-- jinput-dx8.dll
 | |-- jinput-raw.dll
 | |-- lwjgl64.dll
 | |-- lwjgl.dll
 | |-- OpenAL32.dll
 | `-- OpenAL64.dll
 |-- mvn-lib-install.sh
 `-- свт/
 |-- about_files/
 | |-- IJG_README.txt
 | `-- mpl-v11.txt
 |-- about.html
 |-- Линукс/
 | `-- swt.jar
 |-- видео-углерод/
 | `-- swt.jar
 |-- видео-какао/
 | `-- swt_fake.jar
 `-- окна/
 `-- swt.jar

23 каталоги, 77 файлов
+809
Derek Bennett 14 сент. 2010 г., 3:16:19

Я очень новой для Ubuntu и, пожалуйста, медведь со мной, если я представляю очень простыми версия объяснения.

Моя ОС: Убунту 11.10 сервер, 64-разрядная версия

Мне нужно использовать три инструмента samtools, бабочку и цилиндр. Однако цилиндр зависит от samtools и бабочкой. Коэффициент зависимости - выяснить, где находится именно тот путь, на два инструмента (samtools и бабочкой) являются.

Теперь, я могу установить samtools и бабочкой, используя команду sudo apt-получить установку , однако

  • Я не знаю точно, где библиотека путей существует для samtools или бабочкой
  • По установке цилиндр ноты, я, чтобы извлечь инструмент из сжатого файла, сменить реж на этот файл и ./настроить, но я не вижу ./настроить скрипт в извлеченной папке

Samtools и бабочкой и цилиндр находятся на их сайтах, это метод установки я пытаюсь следовать.

+785
Mazee 25 мар. 2010 г., 1:24:08

apt-получить все сказано:

Следующие пакеты были установлены автоматически и больше не требуется:
 гном-файл exe-thumbnailer icoutils libcapi20-3 libgif4 libmpg123-0
 на libnss-смысл libodbc1 libopenal-данные libopenal1 неизвестных смысл odbcinst
 odbcinst1debian2 ТТФ-ТТФ дроид-umefont ТТФ-unfonts-основной unixodbc смысл
 вино-gecko1.4 wine1.4 wine1.4-Общий wine1.4-для i386
Воспользоваться 'apt-получить autoremove', чтобы удалить их.

Выполните команду sudo apt-получить autoremove. Пакет wine1.4-i386, в котором хранится вино исполняемый, будут удалены.

+706
Veronica Albright 23 сент. 2014 г., 0:44:39

Наутилус в настоящее время не имеет возможности для этого.

С технической точки зрения, это действительно не должно быть слишком трудно реализовать. Наутилус использует GtkTreeView виджет для отображения папок, таким образом, он уже имеет возможность прокрутки к определенному элементу в списке. Единственный недостающий элемент-это инструкция от Наутилус рассказать GtkTreeView для прокрутки.

Более сложная задача состоит в том, чтобы убедить гнома развитие команды, что эта прокрутка поведение сделает Наутилус более понятным для обычных пользователей. Если вы хотите заниматься этим, первым шагом является предложить идею на Наутилус в Убунту мозговой штурм страницы. Это разработчики предпочли означает предлагать идеи, которые могут быть быстро программа.

+558
Ashok Basnet 25 нояб. 2015 г., 17:45:57

Платформа: х64 с Lubuntu 11.10

Программа: Гиш

Когда я пытаюсь запустить его из командной строки (/opt/gish/gi.sh), нет проблем. Но когда я пытаюсь запустить его из меню рабочего стола LXDE, она не заводится.

Содержимое /usr/доли/приложения/Гиш.рабочего стола:

[Запись Рабочего Стола]
Категории=Игры;Сайт Actiongame;AdventureGame;ArcadeGame;
Exec=/opt/gish/gi.sh
Путь=/опт/Гиш
Значок=х-Гиш
Терминал=ложь
Тип=Приложение
Имя=Гиш

Я пытался менять терминал=ложь до терминала=истина , чтобы отладить это, но тогда я только что получил пустой терминал, а игра не запускается.

Редактировать:

Вот некоторая дополнительная информация, запрошенная ниже Илии кагала:

  • Я пробовал редактирования /usr/доли/приложения/Гиш.рабочего стола, как это было рекомендовано, но это не имело никакого эффекта
  • Однако, ~/.xsession теперь-ошибки содержались следующие ошибки:

    [: 8: x86_64 с: неожиданный оператор
    ./gish_32: ошибка при загрузке разделяемых библиотек: это libGL.так.1: неправильный класс ELF: ELFCLASS64
    

    Я думаю, что есть проблема с /opt/gish/gi.sh сценарий командной оболочки. Это его содержимое:

    компакт-диск /опт/Гиш/
    
    Uname-м MACHINE_TYPE=``
    если [ ${MACHINE_TYPE} == 'x86_64 с' ]; тогда
    ./gish_64
    еще
    ./gish_32
    интернет
    

    Я не слишком знаком с bash, так что надеюсь, кто-то может указать на ошибку.

    У меня есть 64-разрядная машина. Я думаю, что когда скрипт запускается из командной строки, это нормально запускает 64-разрядную версию (/опт/Гиш/gish_64), но при запуске с рабочего стола LXDE меню, запуск 32-разрядная версия (/опт/Гиш/gish_32), который вызывает это libGL.так.1 ошибка. Однако, это может быть связано с моей это libGL.так.1 Проблемы с 2 Другие игры.

+542
Dwarakesh Pallagolla 24 янв. 2013 г., 8:48:54

Компания fluendo создает двоичный-только DVD-плеер для покупки, которые (якобы) довольно хорошо работает в Ubuntu. Вы можете сделать это из своего интернет-магазина.

Обратите внимание, что в некоторых странах (Финляндии, по крайней мере) даже вступая в дискуссию о обход защиты от копирования является незаконным.

+532
user3089840 23 мар. 2011 г., 0:23:26

Кроме того, при редактировании /usr/share/gnome-background-properties/ubuntu-wallpapers.xml, ommiting по нужным тегам и вовсе позволит вам выбрать плитку, зум, центр, масштаб, заливка или span В внешний вид GUI в настройках.

Пример использования пример Locutus выше:

<обои удаляются="ложных">
 <название>Мой фон</имя>
<имя_файла>/usr/share/backgrounds/my-background.xml</имяфайла>
</обои>
+497
yairks 8 окт. 2010 г., 18:41:42

Ну, я слышал, что Ubuntu-это великолепная операционная система, и я бы хотела попробовать. У меня Макбук, и не хочу, чтобы заменить ОС X горный лев. Как попробовать Ubuntu без удаления ОС Х?

+382
rshimoda 14 авг. 2016 г., 5:27:39

По данным https://wiki.ubuntu.com/AppReviews процесса рассмотрения заявлений хорош как для перед разработчиками программного обеспечения и Ubuntu упаковщиков. Точки, кажется, что разработчикам есть преимущество получать их приложений в центре программного обеспечения быстрее и проще, в то время как они помогают менеджерам пакетов Ubuntu по подготовке их применения для упаковки.

Это, кажется, очень много. Инструкция на вики говорится, что застройщик выполняет некоторые действия, перечисленные здесь, в том числе отправке приложения к НПА, и просит пересмотреть, и через некоторое время он рассмотрен, и принят и включен в репозитории Ubuntu, или не принимают вовсе.

Хотя это выглядит как простой, честный способ быстро добавить приложение в центре программного обеспечения, я думаю, что я упускаю что-то. Я заметил, что, хотя есть некоторые запросы в ожидании, нет (или почти любой) деятельности. Все кажется, как будто он был заморожен около 5-6 месяцев назад, и это пахнет немного заброшенный.

Я понимаю ничего плохого, и все в порядке (может, например, они рассматриваются только в УДС?), или что-то изменилось? Кто-нибудь может объяснить мне внятно, как именно этот процесс комментарии (и включения в репозитории) работает?

+373
Monk27 24 апр. 2019 г., 13:41:59

Aptitude может легко справиться с откатами. Обратите внимание, что вам, возможно, придется откатить некоторые зависимости, как хорошо, но команду, которую вы ищете примерно apt-получить установку пакет xserver-xorg, с=1:7.6+12ubuntu1 (понижение версии точно).

+299
fabiosvm 27 февр. 2016 г., 4:16:44

Возможные Дубликаты:
Как я могу исправить “ошибки искаженной линии” в источниках.список?

Я не могу открыть Диспетчер обновления он говорит:

Е:линии искаженного 54 в списке источников /и т. д./кв/источников.список (дист разбора), 
Е:список источников не может быть прочитан.

Я не могу ничего установить с помощью sudo в мой терминал. Это дает мне то же сообщение. Не могли бы вы сказать мне, в чем проблема. Спасибо.

Что касается Вайшнави

+297
Weebest Christ 4 нояб. 2012 г., 18:43:33

@StErMi, ошибки могут быть связаны с вашей проблемой.

[Ошибка прошивки] совместимость с ACPI(PEGP) определяет _DOD но не _DOS

[Ошибка прошивку]: недопустимый критический порог (0)

ЦУП:intel_dsm_platform_mux_info] *ошибка* мультиплексоры информация сбой вызова

В соответствии с этим, используя acpi_backlight=продавец опциона будет решать первая ошибка. Если это не работает, можно попробовать с ACPI=noirq вариант.

Второй баг, это рекомендуется сделать обновление BIOS и вы видите, что обновление BIOS решило проблему.

В третий один, один обходной путь заключается в использовании линий PCI=noapci вариант, но если вы используете эту опцию, вы не сможете использовать на ATI видеокарты.

Я знаю, что это не навсегда решит вашу проблему, но, по крайней мере, есть надежда, что одним из возможных решений могло бы обеспечить полезной Ubuntu для вас.

Чтобы использовать параметры, указанные здесь, посмотрите на эту ссылку.

+265
nclsvh 21 апр. 2012 г., 17:58:49

Этот новый дизайн еще не живут. Это конструкция, ожидая одобрения. Прочитайте эту статью более внимательно.

+183
Seb Mocci 17 июн. 2010 г., 11:21:04

В моих системах программирования класса, есть недельное Программирование экспериментов, и у меня возникли проблемы с текущей.

Цель заключается в том, чтобы написать программу на C, которая медленно записывает строку текста в файл, измеренные с помощью usleep() в 100 граф для цикла.

Целью эксперимента является наблюдение за буферной размер файла с помощью команды смотреть. Однако, я не могу заставить его работать, используя часы-D ./выход

Какой синтаксис нужен для команды смотреть, чтобы увидеть изменения, внесенные в размер?

+141
katya gushcha 24 апр. 2018 г., 18:07:04

Недавно я установил 12.10. При запуске Gimp, его главное окно опускается ниже нижней части экрана, и не может быть изменен по вертикали, только по горизонтали. Кроме того, окно панели инструментов не отображается правильно; это не имеет названия, и это не подстава. Вместо этого все значки панели инструментов отображаются в одной колонке, которая простирается ниже нижней части экрана. Проблема осталась после переустановки Gimp.

В случае, если это важно, у меня возникли две другие проблемы связанные с графикой: текст в Firefox часто получает искаженный, и вся система периодически зависает, либо в течение нескольких секунд или без возвращения к нормальной жизни. Я бегу интегрированной графикой Intel (контроллер i915).

+116
Zapto 19 авг. 2018 г., 7:01:50

Установка гостевых дополнений не меняется после установки.

Что касается вашего разрешения, вы пробовали установить все драйверы, которые обычно необходимы для вашей системы? Им не уверен, как в VirtualBox работает точно, но я предполагаю, что это 'клонов' хост-системы...

+66
anark10n 7 авг. 2016 г., 10:12:16

Вы можете использовать мобильный конвертер средств для выполнения этих задач.

Mobile Media Converter subtitles window

Вы можете скачать с Здесь.

+26
jExchange 1 авг. 2017 г., 0:35:37

Недавно я установил версию Wubi из Ubuntu12.10. Мне нужно найти версию LibreOffice, установленных на моей системе, но я не могу найти его в любом месте.Кто может мне помочь?

+13
Kaththi Amar 13 дек. 2017 г., 13:38:46

Показать вопросы с тегом